PHP 7.2 unter Debian 9

PHP wurde Ende letzten Jahres in Version 7.2 veröffentlicht und hat damit einen weiteren Meilenstein hinter sich gebracht. Wer jetzt schon die neuen Funktionen nutzen oder einfach nur aktuell sein will, kann PHP 7.2 unter Debian Stretch ganz einfach nachinstallieren.

Ondřej Surý stellt die aktuellsten Pakete in einem Repository zur Verfügung – man muss also zum Glück nicht selbst kompilieren. Um die Pakete zu nutzen, reichen folgende Schritte aus:

Vor dem eigentlichen Upgrade kann man sich kurz die aktuell installierten PHP-Pakete anschauen (z.B. mit dpkg -l | grep php) und die entsprechenden Pakete mit vorangestelltem php7.2 installieren. Beispiel gefällig?

Diese Paketliste ist mit Sicherheit nicht für alle Systeme gültig, daher gilt wie immer: erst denken, dann abschreiben! Ich habe danach die alten php7.0-Pakete mit apt entfernt.

6 Gedanken zu “PHP 7.2 unter Debian 9

  1. Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    libapache2-mod-php7.2 : Hängt ab von: apache2-bin (>= 2.4.16) aber 2.4.10-10+deb8u12 soll installiert werden
    Hängt ab von: libssl1.1 (>= 1.1.0) ist aber nicht installierbar
    php7.2-cli : Hängt ab von: libssl1.1 (>= 1.1.0) ist aber nicht installierbar
    php7.2-common : Hängt ab von: libssl1.1 (>= 1.1.0) ist aber nicht installierbar
    php7.2-curl : Hängt ab von: libcurl3 (>= 7.44.0) aber 7.38.0-4+deb8u11 soll installiert werden
    php7.2-gd : Hängt ab von: libgd3 (>= 2.1.1) aber 2.1.0-5+deb8u11 soll installiert werden
    Hängt ab von: libpng16-16 (>= 1.6.2-1) ist aber nicht installierbar
    Hängt ab von: libwebp6 (>= 0.5.1) ist aber nicht installierbar
    php7.2-readline : Hängt ab von: libncurses5 (>= 6) aber 5.9+20140913-1+deb8u3 soll installiert werden
    Hängt ab von: libtinfo5 (>= 6) aber 5.9+20140913-1+deb8u3 soll installiert werden
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
    root@v8456:/tmp#

Schreibe einen Kommentar